You are here

BMP transparency

ElectrikaL's picture
Fluffy Bunny
Posts: 10
BMP transparency
#1 Submitted: Mon, 22/01/2018 - 12:24

So I was modding some rims and I noticed that the black parts end up transparent ingame.

Any way to fix this?

Using photoshop, I open one of the default rim textures, I then import a new image, resize and overlap it over the default texture and then save.
The thumbnail looks normal with the black showing up but ingame it goes transparent.

Edited by: ElectrikaL on 22/01/2018 - 12:39
Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 3042
Submitted: Mon, 22/01/2018 - 12:38

Make them not-quite-black?

ElectrikaL's picture
Fluffy Bunny
Posts: 10
Submitted: Mon, 22/01/2018 - 12:45

Anything but pure black ends up being way too bright, which is strange because there are default rim texture with pure black parts that show up just fine ingame. I tried to copy that shade of black with the eyedropper tool but it still shows up as transparent.

Edited by: ElectrikaL on Mon, 22/01/2018 - 12:57
Toshiba-3's picture
Velociraptor Fister
Community VIPKickstarter Backer
Posts: 1167
Submitted: Mon, 22/01/2018 - 13:15

There are two blacks in the ingame palette, the first one (IDX 0) is the transparent one so just avoid it. If you want things to be easier, use the carma palette with pink instead of black for IDX 0. Download the "Toshiba's C1 Helpers" from this page http://rr2000.toshiba-3.com/pc-files and load Carma_Tosh.act in Photoshop.

CarmagEdit can also be patched to display/use pink instead of transparent black. (http://qtz.toshiba-3.com/Purple_Palette_Patch_for_All_Carmageddon_Needs.7z)

About things being too bright, if you're running C1 in Glide mode with nGlide, change the gamma to 0.7 in the nGlide settings.

... and carmageddon add-ons at road reaction.

ElectrikaL's picture
Fluffy Bunny
Posts: 10
Submitted: Mon, 22/01/2018 - 14:26

That helped a lot. Thanks.