You are here

[Tool] Minge: The CarMODgeddon Mod Installer

Pages

timmy76's picture
Cunning Stunt Licker
Kickstarter Backer
Posts: 116
Submitted: Thu, 27/08/2015 - 11:41

Yeah first thing I did was run as admin.

Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 2997
Submitted: Thu, 27/08/2015 - 12:48

Has it created the CarMODgeddon folder structure in your C:R folder?

timmy76's picture
Cunning Stunt Licker
Kickstarter Backer
Posts: 116
Submitted: Thu, 27/08/2015 - 14:23

Yeah it created a CarMODgeddon folder but won't let me add any mods as described.

Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 2997
Submitted: Thu, 27/08/2015 - 14:47

Hmm, just scanned through that error log, do you have .NET 4.5 installed or just 4? Minge uses the ZIP compression features of 4.5 so if you've only got 4 installed you need to install the update to .NET to use it.

For the next version I might see about swapping the ZIP handling to us Errol's ZAD classes instead and try compiling the tool for .NET 4 but most people should install 4.5 anyway so it's probably not worth while.

CoffeyCup's picture
Piledriver
Community VIPKickstarter Backer
Posts: 915
Submitted: Thu, 27/08/2015 - 14:58

I've just repacked my BeerWagon mod but for some reason I'm having a problem with the ui_assets. Oddly the larger default_top view shows ingame but the default_minimap and default_side do not?? There's just an empty space.

I even went back to the original PNGs and used Flummery to convert to TDX then repacked ui_assets to get new IMGs. NOTE:The Red Baron's ui_assets show fine. They were not repacked just renamed to ZIP via Minge.

Edited by: CoffeyCup on Thu, 27/08/2015 - 14:59
Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 2997
Submitted: Thu, 27/08/2015 - 15:13

Hmm, that is odd, CoffeyCup. It should be packing all the ui_assets TDX files normally, it no longer needs to convert any textures to IMG. When you open up the ZIP in your favourite ZIP utility, which files does it list in the [CarName]\ui_assets\ path?

CoffeyCup's picture
Piledriver
Community VIPKickstarter Backer
Posts: 915
Submitted: Thu, 27/08/2015 - 16:10

Oh, you're right there are no IMGs now. Just a PNG and TDX for top, side and minimap. Six total.

Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 2997
Submitted: Thu, 27/08/2015 - 16:34

If the TDX files are in the ZIP then they should work, which leads me to think it's more likely a problem with the specific TDX files rather than with Minge. I assume the files are correctly named (e.g. [CarName]_default_minimap.tdx)? Could you try using GibbedTools to convert the TDX files back to PNG and see if they convert okay?

timmy76's picture
Cunning Stunt Licker
Kickstarter Backer
Posts: 116
Submitted: Thu, 27/08/2015 - 16:51

That fixed it Trent
Thought I had .NEtT4.5 installed but remembered my pc had to rebuilt 3 months ago.

CoffeyCup's picture
Piledriver
Community VIPKickstarter Backer
Posts: 915
Submitted: Sun, 30/08/2015 - 01:51

I guess the updated game still uses IMGs for the MiniMap and some menu screens. I finally got my Beer Wagon minimap and side view icons to appear once I checked off "Convert Textures to IMG" when packing them up.

Pages

randomness