You are here

Game not saving after update

Baaw9000's picture
Fluffy Bunny
Posts: 5
Game not saving after update
#1 Submitted: Sun, 03/05/2015 - 17:59

I don't know what's happening my game is refusing to save, auto saving doesn't work and as far as I know there is no way to manual save. I Loose my new progress when I quit, what do I do

jakstak's picture
Fluffy Bunny
PayPal Backer
Posts: 23
Submitted: Mon, 04/05/2015 - 15:03

I've just had the same thing happen to me, After the update the game would no longer save progress,
I asked support and Jason asked me if i had any mods and to remove those and try again,
I did have mods and once i removed them the game saved again,
JS :)

EVGA SR-2, Dual Xeon 5680 Hex, EVGA Classy 980s in 2Way-SLI, 24 Gig Dominator 2000 Ram,
4 SSDs In R0 and 2x1Tb HDD in R0 on an LSI 9212 Raid Card, Everything Under Water

Mad Mike's picture
Velociraptor Fister
Kickstarter Backer
Posts: 1135
Submitted: Mon, 04/05/2015 - 15:31

In addition to career progress not saving while any mods are installed. Setting changes will also not save.

One man... Alone... Wrecking opponents in the Automobile he loves
Twitter Manifestation, Mods for Max Damage

DeathReborn's picture
Fluffy Bunny
Kickstarter Backer
Posts: 5
Submitted: Mon, 04/05/2015 - 17:06

I have the same non saving issues. I have no mods and even get the issue on a brand new install on a separate PC. Ever since the "final" update it hasn't saved anything at all, no mods involved either.

Baaw9000's picture
Fluffy Bunny
Posts: 5
Submitted: Sat, 09/05/2015 - 00:25

Ok I moved my mods in to a driftnet folder in to my desktop, but it still not saving. What should I do now?

Tonrac's picture
Piledriver
Kickstarter Backer
Posts: 550
Submitted: Sat, 09/05/2015 - 09:09

Try to verify the file with steam ... if steam detect a file that is different from the original, he will replace it.

Baaw9000's picture
Fluffy Bunny
Posts: 5
Submitted: Sun, 10/05/2015 - 00:35

Yup I tried that and it still dint save. What am I supo to do?!

DeathReborn's picture
Fluffy Bunny
Kickstarter Backer
Posts: 5
Submitted: Tue, 12/05/2015 - 18:51

Baaw9000 wrote:
Yup I tried that and it still dint save. What am I supo to do?!

Exactly the same here, I think it may only be solved by a "release" update. I have even adjusted security settings for the folders, used the cleanup.bat file in the main directory to no avail.

Tonrac's picture
Piledriver
Kickstarter Backer
Posts: 550
Submitted: Tue, 12/05/2015 - 18:58

do you try to reinstall the game completely?

DeathReborn's picture
Fluffy Bunny
Kickstarter Backer
Posts: 5
Submitted: Tue, 12/05/2015 - 23:26

Tonrac wrote:
do you try to reinstall the game completely?

I even tried a PC it's never been installed on and the same issue occurs. For further info this is the current SESSION_LOG.TXT file contents:

12/05/2015 00:16:15-> Version info
Configuration PC Steam Public
Build Number  6939
Build LB	  
Build BZ      
Date          28/04/2015

12/05/2015 00:16:15-> Show splash screen
12/05/2015 00:16:15-> Initialising steam.
12/05/2015 00:16:15-> Enabling steam features.
12/05/2015 00:16:15-> Entering main game loop.
12/05/2015 00:16:15-> Game:Initialise
Physical RAM : 4095MB
64bit OS     : Yes

12/05/2015 00:16:15-> Starting Beelzebub.
12/05/2015 00:16:15-> Game:Initialise left.
12/05/2015 00:16:15-> Game:Startup
12/05/2015 00:16:15-> Load user config.
12/05/2015 00:16:15-> Initialise content system.
12/05/2015 00:16:15-> Setup texture profiles.
12/05/2015 00:16:15-> Create game setup info.
12/05/2015 00:16:15-> Load localisation.
12/05/2015 00:16:15-> Fetch player profile.
Profile not found, creating defaults.
12/05/2015 00:16:15-> ...
12/05/2015 00:16:15-> Initialise UI.
12/05/2015 00:16:15-> ...
12/05/2015 00:16:15-> ...
12/05/2015 00:16:15-> Initialise Graphics.
GPU			 : AMD Radeon R9 200 Series
Dedicated    : 3072MB

12/05/2015 00:16:18-> Remove splash screen.
12/05/2015 00:16:18-> Load audio.
12/05/2015 00:16:18-> Initialise movie support.
12/05/2015 00:16:18-> Initialise input.
12/05/2015 00:16:19-> Startup UI.
12/05/2015 00:16:19-> Game:Load.
12/05/2015 00:16:19-> Game:Load left.
12/05/2015 00:16:19-> Game:Startup left.

That was start a game, config visual settings to 1080p and do the first event then leave and re-enter the game. It resets everything including the settings. Also the Carmageddon Reincarnation folder in Documents is empty whereas before it had a single file in it.

SCRIPT_LOG.TXT has the following:

WARNING! Modified ZADs
[lua] C:\BuildAgent\work\7b44635f93fe5d3c\Build\Data_Core\Content\UI\logic\frontend\auto_save_warning.lua:20: 
call parameter mismatch - too many or too few a parameter count declared, method save in class CLuaGameSave

I can confirm there has been no modifications at all, this is a fresh download today of the game (my 7th since the problem occurred).

Trent's picture
I was in the War!
Community VIPKickstarter BackerCompetition Winner
Posts: 2997
Submitted: Wed, 13/05/2015 - 10:45

Just to be sure, these 94 files should be the only ZAD files in the ZAD folder:

Accessories.zad
Audio_Scripts.zad
Effects.zad
env_bleak_city.zad
env_bleak_city_accessories.zad
env_dusty_trails.zad
env_dusty_trails_accessories.zad
env_frosty_pass.zad
env_frosty_pass_accessories.zad
env_magnuchem.zad
env_magnuchem_accessories.zad
lev_bleak_city_business_district.zad
lev_bleak_city_business_district_accessories.zad
lev_bleak_city_outskirts.zad
lev_bleak_city_outskirts_accessories.zad
lev_bleak_city_sumo.zad
lev_bleak_city_sumo_accessories.zad
lev_dusty_trails_island.zad
lev_dusty_trails_island_accessories.zad
lev_dusty_trails_national_park.zad
lev_dusty_trails_national_park_accessories.zad
lev_frosty_pass_iceberg.zad
lev_frosty_pass_iceberg_accessories.zad
lev_frosty_pass_rig_wreck.zad
lev_frosty_pass_rig_wreck_accessories.zad
lev_magnuchem_arena.zad
lev_magnuchem_arena_accessories.zad
lev_magnuchem_reprocessor.zad
lev_magnuchem_reprocessor_accessories.zad
Materials.zad
Models.zad
Movies.zad
peds.zad
Pickups.zad
powerups.zad
scripts.zad
shaders.zad
Text.zad
textures_final.zad
textures_fonts.zad
textures_frontend.zad
textures_particle.zad
UI_Assets.zad
UI_Scripts.zad
Vehicle_Annihilator.zad
Vehicle_APC.zad
Vehicle_Bear.zad
Vehicle_Caddy_Fat_Cat.zad
Vehicle_Cleaver.zad
Vehicle_Countslash.zad
Vehicle_Crazor.zad
Vehicle_DeGoryun.zad
Vehicle_Eagle_R.zad
Vehicle_Electric_Blue.zad
Vehicle_Hawk.zad
Vehicle_Lumberer.zad
Vehicle_Mega_Woot.zad
Vehicle_Plow.zad
Vehicle_Razor.zad
Vehicle_Scripts.zad
Vehicle_Siamese_Dream.zad
Vehicle_Snaky_Bastard.zad
Vehicle_Squad_Car.zad
Vehicle_Stiffshifter.zad
Vehicle_Suppressor.zad
Vehicle_Tashita.zad
Vehicle_Towmeister.zad
Vehicle_Twister.zad
Vehicle_Volkswerker.zad
Weapons.zad
Wheels_Annihilator.zad
Wheels_APC.zad
Wheels_Bear.zad
Wheels_Caddy_Fat_Cat.zad
Wheels_Cleaver.zad
Wheels_Countslash.zad
Wheels_Crazor.zad
Wheels_DeGoryun.zad
Wheels_Eagle_R.zad
Wheels_Electric_Blue.zad
Wheels_Hawk.zad
Wheels_Lumberer.zad
Wheels_Mega_Woot.zad
Wheels_Plow.zad
Wheels_Razor.zad
Wheels_Siamese_Dream.zad
Wheels_Snaky_Bastard.zad
Wheels_Squad_Car.zad
Wheels_Stiffshifter.zad
Wheels_Suppressor.zad
Wheels_Tashita.zad
Wheels_Towmeister.zad
Wheels_Twister.zad
Wheels_Volkswerker.zad

And in the ZAD_VT folder there should be four folders, each containing an Environments.zad and 16 Pages_#.zad files and nothing else. If there's any other ZAD file in any of those folders then the game will think there's mods installed. By the look of that error message it seems that the problem could lie with UI_Scripts.zad.

When you say you have reinstalled it, have you deleted the entire folder from your SteamApps\common\ directory before reinstalling? If you just uninstall it from Steam it will leave the folder there along with any files which aren't part of the game's manifest. For a complete clean installation you need to delete the folder manually after uninstalling it.

If you keep having problems then you need to submit a support ticket here: https://carmageddon.zendesk.com/hc/en-us/requests/new

randomness