You are here

Carmageddon 3dfx running slow in Windows 8.1

Pages

Tebbitbreath's picture
Fluffy Bunny
Posts: 2
Carmageddon 3dfx running slow in Windows 8.1
#1 Submitted: Sun, 01/02/2015 - 06:19

Hello, I got the Carmageddon Max Pack version from GOG, and when I try to run the 3dfx mode, the game goes very slow. I even tried the Experimental Patch and the game ran more stable but it's still slow. I've looked into the forums for possible solutions but I didn't find anything that has worked so far. :( Any solutions for this?

Thanks! :)

Edit: Fixed it by opening the game with Carm95.exe (C:\GOG Games\Carmageddon\CARMA\Carm95.exe) instead of the Dosbox shortcut.

Edited by: Tebbitbreath on 01/02/2015 - 07:21
Toshiba-3's picture
Velociraptor Fister
Community VIPKickstarter Backer
Posts: 1134
Submitted: Sun, 01/02/2015 - 12:32

You can also edit dosboxCARMA_single.conf in notepad and replacing the line that says:
3dfx.exe
with
voodo2c.exe -vrush

Then try the 3DFX mode again, it might run a little better. Other options are to update nGlide, or replace it with another glide wrapper like dgVoodoo.

But IMO playing with Carma95 is best :)

Edited by: Toshiba-3 on Sun, 01/02/2015 - 12:33

... and carmageddon add-ons at road reaction.

Tebbitbreath's picture
Fluffy Bunny
Posts: 2
Submitted: Sun, 01/02/2015 - 16:53

Thank you for the response, I'll try those steps. Thanks Toshiba. :)

Breakin'Benny's picture
Piledriver
Posts: 745
Submitted: Sun, 01/02/2015 - 20:39

Toshiba-3 wrote:
You can also edit dosboxCARMA_single.conf in notepad and replacing the line that says:
3dfx.exe
with
voodo2c.exe -vrush

Then try the 3DFX mode again, it might run a little better. Other options are to update nGlide, or replace it with another glide wrapper like dgVoodoo.

But IMO playing with Carma95 is best :)

Tebbitbreath wrote:
Thank you for the response, I'll try those steps. Thanks Toshiba. :)

Better not forget to enable "hardware mode", or more precisely "high-res SVGA" mode to improve the look whilst also making use of the cnc-ddraw mod

jimmy1333's picture
Fluffy Bunny
Posts: 30
Submitted: Tue, 03/02/2015 - 01:42

Toshiba-3 wrote:
You can also edit dosboxCARMA_single.conf in notepad and replacing the line that says:
3dfx.exe
with
voodo2c.exe -vrush

Then try the 3DFX mode again, it might run a little better. Other options are to update nGlide, or replace it with another glide wrapper like dgVoodoo.

But IMO playing with Carma95 is best :)

Hey, I was wondering, is there any thing similar to Carma95.exe on the Steam release? I can only play with 3dfx and it lags horribly (I also prefer Carma95.exe from the gog version but for simplicity's sake i got it on Steam) Are steam users doomed D:

Toshiba-3's picture
Velociraptor Fister
Community VIPKickstarter Backer
Posts: 1134
Submitted: Tue, 03/02/2015 - 11:22

The Carma95 patch was said to be coming for the Steam release too but I doubt it'll ever be..?
You could copy the whole GOG version (with the win95 patch applied) and replace the Steam one (Steam one is actually the GOG one but then without Carma95). I guess it's somehow possible to redirect the Steam link to CARM95.EXE rather than to dosbox.exe? I never tried.

... and carmageddon add-ons at road reaction.

jimmy1333's picture
Fluffy Bunny
Posts: 30
Submitted: Tue, 03/02/2015 - 13:16

Toshiba-3 wrote:
The Carma95 patch was said to be coming for the Steam release too but I doubt it'll ever be..?
You could copy the whole GOG version (with the win95 patch applied) and replace the Steam one (Steam one is actually the GOG one but then without Carma95). I guess it's somehow possible to redirect the Steam link to CARM95.EXE rather than to dosbox.exe? I never tried.

Hey, you are right I'm gonna try that. What if I redirected it by naming Carm95.exe to dosbox.exe and viceversa?? I can't now but I'm gonna try this later and report back!

Edited by: jimmy1333 on Tue, 03/02/2015 - 13:16
jimmy1333's picture
Fluffy Bunny
Posts: 30
Submitted: Tue, 03/02/2015 - 19:35

Okay I did try it. I overwrote the Steam installation with GOG's (and the Win95 patch). However when I try to load a game via carma95.exe I get a "Please insert Carmageddon CD" (lol!) So I guess it doesnt work. Is there a way to emulate how the win95 patch performs & looks with Dosbox? I wish we could ask nobby or the community manager about the win95 patch :(

Toshiba-3's picture
Velociraptor Fister
Community VIPKickstarter Backer
Posts: 1134
Submitted: Wed, 04/02/2015 - 14:58

Aah right should have thought about that :P
Well you can first try to download the Meld Pack and replace the CARM95 executable from your Steam folder with the one from the pack (maybe also DATA\PATHS.TXT).

Or, to reply to your question, you can simply launch Carmageddon via Steam and choose the second option in dosbox and it will run C1 in the same res and mode as Carm95 (but within dosbox thus). Then you just alt-enter out of fullscreen mode or edit dosboxCarma.conf so:
fullscreen=false

... and carmageddon add-ons at road reaction.

jimmy1333's picture
Fluffy Bunny
Posts: 30
Submitted: Wed, 04/02/2015 - 15:35

Yeah, I did the second thing you mentioned. However the res is a lot lower then Carma95 -hires. I think I'm sticking to this one though (dosbox second option in low res). I'm gonna try using dgVoodoo 2 with C1 and report back on how it works!

jimmy1333's picture
Fluffy Bunny
Posts: 30
Submitted: Wed, 04/02/2015 - 16:13

Okay I tried both dgVoodoo 2.32 (got it off your site) and 2.41 and neither worked apparently. When I launch the game nothing happens, maybe I have to modify dosboxCARMA or dosboxCARMA_single? (Steam says I'm playing it, however) some file is created and then disappears when the process dies. I extracted the contents to the DOSBOX folder.

Btw I tried the GOG installation (placing it on the steam directory +win95 patch +meld from your site but It still asks me to insert the CD and crashes shortly after so that's a no-go I guess)

Edited by: jimmy1333 on Wed, 04/02/2015 - 16:49

Pages

randomness