You are here

Addon car not working properly

MightyCucumber's picture
Fluffy Bunny
Posts: 4
Addon car not working properly
#1 Submitted: Fri, 11/04/2014 - 16:27

Hey, what's up? I've been downloading some cars for Carma 1, but I'm having a problem with one of them. It seems I'm not able to screenshot it right now (the printscreen only displays the DOSBox window), but the thing is the entire car is blue - it runs, it bashes against the others, it's animated and all that, but the texture looks as if it hasn't been applied...

The car in question is the Beast by Tosh if anyone's wondering. Care to give a little help? :)

Cheers,

Mighty

Edited by: MightyCucu... on 11/04/2014 - 16:28
hazardic's picture
Cunning Stunt Licker
Kickstarter Backer
Posts: 499
Submitted: Fri, 11/04/2014 - 17:16

lemme guess - you launch it under glide via dosbox? the answer is simple - due to texture size of this addon car, it works properly only in software mode, along with some others. try another one and it will work fine - for instance, econobrick eagle

MightyCucumber's picture
Fluffy Bunny
Posts: 4
Submitted: Fri, 11/04/2014 - 17:53

Yup, that's it (I think?...). How do I run it on software mode without having crappy resolution? Being new around here, I still don't know pretty much anything about running the game properly in W8.

By the way, just installed the converted Abba Cab from RR and it crashes my game. Same issue or is my guess wrong?

hazardic's picture
Cunning Stunt Licker
Kickstarter Backer
Posts: 499
Submitted: Tue, 15/04/2014 - 07:14

MightyCucumber wrote:
Yup, that's it (I think?...). How do I run it on software mode without having crappy resolution? Being new around here, I still don't know pretty much anything about running the game properly in W8.

unfortunately i don't know about working carma in w8, especially in software mode. all i can suggest is to try hifi's DirectDraw patch (CARM95 only) - you can get it on RR in the files section or directly from hifi's plce - http://hifi.iki.fi/cnc-ddraw/. all i can tell is that it works fine with w7 apart with custom hires modes (basically - unlimited) and some other worthy things. try it

MightyCucumber wrote:
By the way, just installed the converted Abba Cab from RR and it crashes my game. Same issue or is my guess wrong?

abba cab works fine with my game in both modes, software and glide. so maybe you should check your opponents file - u may have missed proper opponent count or smth else. anyway, check it out attentively

Toshiba-3's picture
Velociraptor Fister
Community VIPKickstarter Backer
Posts: 1117
Submitted: Tue, 15/04/2014 - 09:59

Hello, I indeed don't tend to support the C1 glide much. Didn't know about the texture limitation when I ported these models back then, nothing to do about that now I'm afraid. The details of each car at RR usualy mention if there's a problem with glide or something else. Hifi offers a patch that will modify the carm95 executable to make it always run in hires, you might want to do that before using ddraw.dll (or else make a shortcut to the game with the -hires parameter at the end of the path). It's also possible to use custom internal resolutions (up to 1920x1080) but it's experimental and doesn't stretch some ingame bitmaps like the menus, cockpits or minimaps. I'm running Windows 8 and all Carmas work fine BTW.

About Abba Cab, try to install it again?

... and carmageddon add-ons at road reaction.